Back to overview
Degraded

Weather services disruption

Mar 11 at 04:41am AEDT
Affected services
Operations Center

Resolved
Mar 11 at 11:01am AEDT

Weather services are fully operational again.

Created
Mar 11 at 04:41am AEDT

We're experiencing an issue with our weather service provider. Weather forecasts and other weather-related services are currently unavailable. Our team is working on a resolution, and we appreciate your patience while we get things back to normal.